Ich bekomme seit heute Morgen die Warnung:

LaTeX Warning: Command \InputIfFileExists has changed. Check if current package is valid

Das passiert schon bei einem ganz einfachen Beispiel wie

\documentclass{scrartcl}
\begin{document}
Test
\end{document}

Das Ergebnis sieht dann zwar aus wie immer, aber die Warnung wird ja sicher eine Ursache haben. Allerdings sehe ich in obigem Code keine Ursache.

gefragt 07 Okt '19, 16:06

der_zornige_juergen's gravatar image

der_zornige_...
257210
Akzeptiert-Rate: 37%


Du hast vermutlich ein Update deiner TeX-Distribution gemacht und dabei eine neue Version des LaTeX-Kerns erhalten. Ab der aktuellen Version LaTeX2e <2019-10-01> (die Angabe ist ziemlich am Anfang der log-Datei eines LaTeX-Laufs zu finden) ist die Anweisung \InputIfFileExists nicht mehr mit \long\def definiert, sondern mit \DeclareRobustCommand als robuste Anweisung. Die im Beispiel verwendete KOMA-Script-Klasse lädt das Paket scrlfile, das (laut Doku) \InputIfFileExists umdefinieren muss, um zusätzlichen Code vor oder nach dem Laden der Datei ausführen zu können. Dabei geht es in der von dir verwendeten Version von der früheren Definition von \InputIfFileExists aus, testet vor der Umdefinierung aber mit \CheckCommand, ob die Definition den Erwartungen entspricht. Ist das nicht der Fall, so gibt LaTeX bei \CheckCommand obige Warnung aus.

Die Ursache ist also ein Update auf eine neue LaTeX-Version bei gleichzeitiger Verwendung eines Pakets, das diese Version noch nicht unterstützt. Das Problem ist laut Release-Informationen zu KOMA-Script 3.26b ab KOMA-Script 3.27.3234 bereits behoben und damit auch in der aktuell verfügbaren offiziellen KOMA-Script Release auf CTAN, in TeX Live und MiKTeX.

Solange man kein Update von KOMA-Script installiert hat, dürfte das Problem aber nur in wenigen Fällen eine Rolle spielen, beispielsweise, wenn man eine \InputIfFileExists-Anweisung innerhalb eines moving arguments verwendet.

Permanenter link

beantwortet 07 Okt '19, 16:25

Ijon%20Tichy's gravatar image

Ijon Tichy
9.6k31227
Akzeptiert-Rate: 53%

bearbeitet 30 Okt '19, 12:09

Ich habe mich dann doch für das Update auf die neuste KOMA-Script-Prerelease entschieden (eine ältere hatte ich ohnehin schon installiert). Ist bekannt, wann es eine neue richtige Release (dann wohl 3.27 oder 3.28?) geben wird?

(07 Okt '19, 16:45) der_zornige_...
Deine Antwort
Vorschau umschalten

Folgen dieser Frage

Per E-Mail:

Wenn sie sich anmelden, kommen Sie für alle Updates hier in Frage

Per RSS:

Antworten

Antworten und Kommentare

Markdown-Grundlagen

  • *kursiv* oder _kursiv_
  • **Fett** oder __Fett__
  • Link:[Text](http://url.com/ "Titel")
  • Bild?![alt Text](/path/img.jpg "Titel")
  • nummerierte Liste: 1. Foo 2. Bar
  • zum Hinzufügen ein Zeilenumbruchs fügen Sie einfach zwei Leerzeichen an die Stelle an der die neue Linie sein soll.
  • grundlegende HTML-Tags werden ebenfalls unterstützt

Frage-Themen:

×22

gestellte Frage: 07 Okt '19, 16:06

Frage wurde gesehen: 2,671 Mal

zuletzt geändert: 30 Okt '19, 12:09